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Classifying SEDs of Herbig Ae/Be Stars

Abstract

Herbig Ae/Be stars are 2-8 solar mass, pre-main-sequence stars

(that is, young objects with typical ages of < 10 Myr) of spectral

types  A  or  B.  These  stars  are  still  embedded  in  gas-dust

envelopes  and  are  sometimes  accompanied  by  circumstellar

disks.  They  are  in  the  gravitational  contraction  stage  and

approaching  the  main  sequence  (i.e.  they  are  not  burning

hydrogen in their centre).

Herbig  Ae/Be stars  show Balmer emission lines in  their  stellar

spec-trum  and  infrared  excess  due  to  circumstellar  dust.

Sometimes  Her-big  Ae/Be  stars  show  significant  brightness

variability associated to clumps (protoplanets and planetesimals)

in  the  circumstellar  disk.  The SEDs  of  Herbig  Ae/Be  stars  fall

roughly into two groups: Group I sources have a relatively strong

far-IR ux,  which is  energetically  comparable with  the ux in the

near-IR showing an almost at spectral energy distribution. Group

II sources show a similar near-IR excess as group I sources but

their  flux falls  off  strongly  towards  the  far-IR.  These were  first

classified by Meeus et al (2001, A&A, 365, 476). Examples of both

groups are seen in the plot above. In this tutorial we will use VO

tools  and  services  to  access  observed  photometric  SEDs  and

spectra in the near and far infrared of different stellar objects to

compare them and classified them into group one or group two.

Software: SPLAT   Version 3.11, Topcat   Version 4.5

1. Starting out

For this tutorial we need the VO tools Topcat and Splat-VO. You can find the most recent versions
here:

TOPCAT: http://www.star.bris.ac.uk/~mbt/topcat/
Splat-VO: http://www.g-vo.org/pmwiki/About/SPLAT

2. SAMP and SSAP

The Virtual Observatory (VO) is all about interoperability of astronomical data. Within the different
VO  projects,  services  and  client  softwares  are  developed  speaking  common  languages
(protocols)  which   facilitates  remote  access  to  different  data   types  like  tables,  images  and
spectra.  In this tutorial  we will  make use of  the VO standards Simple Application Messaging
Protocol (SAMP) and Simple Spectral Access Protocol (SSAP).  Don't be afraid, you will almost
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not notice when we use either one of them, but will soon see how useful they are, to discover and
access observational data of e.g. the Herbig Ae/Be stars HD100546 and HD163296.

3. Workflow

• Search and download Photometry Points: In this  first step we will download photometry from Vizier

and prepare the data in Topcat. In a later step we will load this data into Splat-VO. For now, start
Topcat.  Then  open  a  Browser  and  access  the  Vizier  Photometry  Tool  at:  http://vizier.u-
strasbg.fr/vizier/  sed/. At Target enter HD100546 and at Radius enter 1. After a few seconds the
service presents you the plot of the photometric data points of HD100546 (Figure 1). Below the
plot you see a list of catalogues in Vizier that provide photometry. You can select and deselect
whole catalogues or single data records to be plotted.

•

Figure 1: The Vizier Photometry Service

Now we want to obtain the data from the service and have a look at it. One way would be to click

on download data, but it is more convenient to directly transfer the data to your desktop using a

VO protocol called SAMP. To use it, spot the image of a radio dish right below the blue submit

button (look at the upper left of Fig. 1 where to find it). Click on it once and a button broadcast will

appear. Click  on it,  and a window will  open that  asks you if  you want  to  accept  the SAMP

connection.  SAMP is  used  to  exchange data  between different  VO tools.  In  this  case,  your

http://vizier.u-strasbg.fr/vizier/sed/
http://vizier.u-strasbg.fr/vizier/sed/
http://vizier.u-strasbg.fr/vizier/sed/


browser will  send the photometric catalogue data to Topcat. Click on Yes and change to the

Topcat main window.

• Make a table subset: In Topcat in the table list you can see the entry data from Vizier photometry

viewer. Topcat also informs you that there are 130 rows in the table. 

To produce a usable SED, we need to process this dataset a bit, in particular by filtering out
obviously problematic records. To do that, go to Views → Table Data to have a look into the data.
Sort  by  the  column _sed_filter.  For  these  particular  objects  (Herbig  Ae/Be)  we  should  pay
particular attention to optical and infrared data; hence, select 1 record for each band from the
following surveys (hold the control key and click on the rows): 2MASS , AKARI, Gaia, HIP, IRAS
and WISE. Then go to  Subsets → Subset from Selected Rows. You will be asked to name the
subset. Then, click Add subset.

• Send data to Splat-VO: Our analyis will take place in Splat, so that's where we need to send the 
data to; again, we can use SAMP for that.

Open Splat-VO and then return to Topcat's main window. To make sure only our cleaned-up 
dataset is transferred to Splat, on the right side in Current Table Properties,  at Row Subset 
select the subset we defined in the previous step.

Then, in TOPCAT, go to  Interop → Send Table to … → splat. Going back to Splat-VO you will
now see the table containing the photometry, as well as a open plot, which looks nothing like a
SED; that's because Splat could not work out what columns contain the spectral and flux columns
are (that's called an "`interoperability problem"' in the VO jargon and can count for a bug). To fix
this, go to Splat-VO's main window and in Properties of current spectra. Under Columns select
sed freq as Coordinates and sed flux as Data. In the Line type menu select point. Play a little with
the settings to get familiar with the various plot options.

•   Get infrared spectra:  The points we have aren't really enough to tell  apart the two classes of

Herbig Ae/Be stars. So, in this step we will search for spectra in the near and far infrared. To do
that,  we will  use a VO standard called Simple Spectral  Access Protocol (SSAP) that  lets us
search for spectra with all kinds of constraints and pull whatever we find into Splat-VO.

•

So, in the main SPLAT-VO window, go to  File → SSAP to open a new window (“Query VO for
spectra”). On the left side you find options that are related to the services, whereas on the right
side you can set configurations concerning the object or position of interest. Let's start with the
servers. We are interested in spectra in the infrared, so, at SSAP Servers, we select the ISO ESA
archive SSAP service. On the right side of the window we now make the settings for the object. At
Object  enter  HD100546 and  then  click  lookup.  This  will  resolve  the  object  identifier  to
coordinates. The Radius with 10 arcminutes is a little too big (you'll get false matches); better set
it to 1 arcminute. Finally, press Send Query.

The query results will show up. You'll see that there's quite a bit of metadata on each spectrum;
this already lets you work out which spectra might be useful for your analysis. Unfortunately, at
the time of this writing, not all metadata from the ISO service is in perfect order. If in doubt, just
have a look at the spectrum itself. Anyway, the two spectra you want here are the last two spectra



in the list (ISO SWS01 and ISO LWS01). Select them by holding the control key and clicking on
the rows.  Press  Download Selected to download the spectra.  After a few seconds,  the two
spectra will appear on the left side of the main SPLAT window. 

•    How not to get lost: In Splat-VO's main window you will see the stack of spectra. Right now you
should see the table containing the photometric points and two spectra, so keeping the overview
here seems easy.  The more data you download, the more difficult it gets to keep that overview.
We suggest  that  whenever  you  want  to  keep  a  downloaded  spectrum,  you  give  it  a  more
expressive name by changing the Short name entry. Do so now for the photometry points from
VizieR and the (two) spectra from ISO. Below we will open spectra of different objects, so it is a
good idea to also include some indication of the object name (HD 100546).

• Unify units: We will now merge the photometry with the spectra to a SED in a single plot. For this
to work, we need to unify the units in the various pieces of data. To do this, in the SPLAT main
window, go to  View → View/modify pectral coordinates. You will recognise that the units of the
spectra and the photometry table are different. Simply select all three entries in the Global list of
spectra and then below, at Coordinate System ,select Wavelength in vacuum and at units select
Angstrom. Then click on Convert and, then, on Close.

The analogous step for the flux axis employs: View → View/Modify data units. Again, select the
photometry  table  and  the  spectra  in  the Global  list of  spectra.  At  Units  select  erg/cm^
2/s/Angstrom. Then click on Convert and, then, on Close. 

These  little  magic  trick  show you  how easy  many  things  can  become if  people  use  proper
standards and clients. (As an aside, when you have to use data without proper metadata, you can
enter the proper units and hit the Set button in that dialogue).

• Plotting: Finally we can have a look at the SED plot: In the main window of Splat-VO select the
photometry table an the two spectra and click on View → Display/add to plot.

Since we are spanning several  orders  of  magnitude  and flux,  the  default  plot  is  not  terribly
informative. The physics here strongly suggests a log-log plot, so change the scale to logarithmic
by checking log on both axes. 

•
Fig. 2 shows the SED for HD100546, taken aside the colours, your SED should look similar.

•    Adding a second object: As we stated in the abstract, Herbig Ae/Be stars fall into two groups, so

we now will access data of a second object and then compare the plots. We do this by repeating
the previous steps for the object HD163296. Note that during the spectra selection process you
select the spectra ISO SWS 01 and ISO PHT40.



Figure 2: The plot of the SED of HD100546

•  What to do when Splat ignores the log check mark: When trying to change the scale of the Y Axis

to log you may notice that Splat sets the check mark but doesn't change the plot. This is due to a
bug in the current version. If this isn't fixed in your version of Splat, try a quick workaround. The
root of the problem is that when there are negative ux values (as in some ISO spectra), Splat
catches the math exception but then does nothing useful (e.g., replacing it by a NULL or at least
undo the check mark in log).

To still see something, select the spectrum in question in the Splat-VO main windows, then go to
View → View/modify spectra values. In the opening window, uncheck Read only, then click on
operations  →  Modify  data  column.  In  the  newly  opening  window  we  can  apply  algebraic
expressions to all data values of the spectra.

Since  with  ux  calibrated  data,  negative  values  only  make  sense  as  the  formal  result  of  a
(frequentist) error estimate, it doesn't really matter what we do to them for this analysis. A very
quick hack that will let you do the log plot is replacing the flux values with absolute values; you
can do that  by entering  abs(data)  next  to y= type (you should get  fancier  in  less qualitative
analyses). Then click Apply and Close. 

• Plot two objects: We will now have a look at both objects in the same plot. You can do so from the

Splat-VO main window by adding the SED and spectra of HD163296 to the plots of HD100546.
You could also select the SED and spectra in the main window and click on Views → Display/add
to plot. The result should look similar to Fig. 3.



If you compare the two objects, you can easily see that HD100546 shows an excess in the near
and far infrared, which the model says is due to the existence of dust surrounding the star and
emitting in these bandpasses. Hence HD 100546 a Herbig Ae/Be star of group I, and HD 163296
Herbig Ae/Be star of group II.

Figure 3: The SEDs of HD100546 and HD163296, as displayed by Splat-VO

4. Additional work

Repeat the above steps for AB Aurigae and categorise the star to one of the groups.
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